Official Pawn forums Forum Index
  
Crashing ?

 
Post new topic   Reply to topic    Official Pawn forums Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
sedious



Joined: 30 Nov 2008
Posts: 3

PostPosted: Sun Nov 30, 2008 9:35 am    Post subject: Crashing ? Reply with quote

Hi, i have had pawn running once but not since. Has anyone had this problem, and how did they fix it ?

Whenever i enable pawn wow crashes with the following message:

Quote:
This application has encountered a critical error

ERROR #132 (0x85100084) Fatal Exception
Program C:\games\wow eu\wow.exe
Exception 0xC0000005 (ACCESS_VIOLATION) at 001B:0077E6E8

The Instruction as "0x007E6E8" referenced memory at "0x00000004"
The memory could not be "read"

Press OK to terminate the application


Thanks for any help...
Back to top
View user's profileSend private message
sedious



Joined: 30 Nov 2008
Posts: 3

PostPosted: Sun Nov 30, 2008 4:23 pm    Post subject: Reply with quote

Should add that i am using the latest v of pawn from curse, and latest wow.
Back to top
View user's profileSend private message
Vger
Pawn Mod Creator


Joined: 09 Jul 2007
Posts: 120
Location: Azjol-Nerub (US)

PostPosted: Sun Nov 30, 2008 6:32 pm    Post subject: Reply with quote

I've had one recent report of a crash possibly related to Pawn, on Curse. Hope you don't mind if I copy-paste what I said there. :)

Sorry to hear that it's giving you problems. Does it only happen when ONLY Pawn is enabled? There are two things you can do:

(1) ALWAYS send crash reports when asked to by the game or Windows, so Blizzard can find out about the problem
(2) If you can reproduce this problem consistently, post about it on the technical support forums with as much detail as you can, including details about your hardware (they'll probably ask for "dxdiag" info)

Unfortunately, without a way to reproduce this myself, there isn't anything I can do about it as it's a game crash. :(
Back to top
View user's profileSend private messageVisit poster's website
sedious



Joined: 30 Nov 2008
Posts: 3

PostPosted: Mon Dec 01, 2008 4:47 am    Post subject: Reply with quote

It seems to be an addon conflict - working on giving you more info.
Back to top
View user's profileSend private message
Mammothe



Joined: 30 Dec 2008
Posts: 1

PostPosted: Tue Dec 30, 2008 3:01 pm    Post subject: Reply with quote

I have the exact problem. When I enable the addon WoW crashes. If I disable WoW runs fine. I'll post specific info here and on the WoW forums when I get home.
Back to top
View user's profileSend private message
tazdvl2000



Joined: 02 Jan 2009
Posts: 1

PostPosted: Fri Jan 02, 2009 11:18 am    Post subject: Reply with quote

I'm having the same problem. I tried a earlier version of Pawn and it didn't hard crash, but it did get errors that were reported by bug swatter or some other addon I have. Looking forward to the next release, hoping this bug gets elimanated.
Back to top
View user's profileSend private message
Vger
Pawn Mod Creator


Joined: 09 Jul 2007
Posts: 120
Location: Azjol-Nerub (US)

PostPosted: Fri Jan 02, 2009 4:03 pm    Post subject: Reply with quote

The bug won't go away on its own. Please be sure to always submit crash reports when it happens, and if you can come up with a reproducible way to get it to crash, be sure to post it and any details of your hardware that you can on the official technical support forums.
Back to top
View user's profileSend private messageVisit poster's website
EvilGrin



Joined: 06 Jan 2009
Posts: 5

PostPosted: Tue Jan 06, 2009 12:43 pm    Post subject: Reply with quote

I'm having the same hard crash issue. It's reproducable accross all my characters.

I'm going to have to roll a level 1 char and enable my addons one by one to find out where the conflict is. :/
Back to top
View user's profileSend private message
EvilGrin



Joined: 06 Jan 2009
Posts: 5

PostPosted: Tue Jan 06, 2009 1:39 pm    Post subject: Reply with quote

Ok I've debugged this. The crash is being caused by a bug in Pawn. I have started a seperate thread that illustrates the actual error here.

The following instructions will allow you to work round the bug.

1. Open your World of Warcraft Folder. (Usually, C:\Program Files\World of Warcraft)
2. Navigate to your Characters Saved Variables Folder (Usually <WoW Folder>\WTF\ACCOUNTNAME\Server Name\Character Name\SavedVariables\).
3. Copy and Paste the following into a new file you should call 'Pawn.lua'.

Code:

PawnOptions = {
   ["ShowEnchanted"] = true,
   ["Digits"] = 1,
   ["ShowSpace"] = false,
   ["AlignNumbersRight"] = false,
   ["ShowTooltipIcons"] = true,
   ["ShownGettingStarted"] = true,
   ["ShowItemID"] = false,
   ["ShowUnenchanted"] = true,
   ["Debug"] = false,
   ["ButtonPosition"] = 2,
   ["ShowItemLevel"] = false,
   ["ShowAsterisks"] = 1,
   ["Scales"] = {
      ["Pawn value"] = {
         ["Values"] = {
            ["Intellect"] = 1,
            ["ArcaneResist"] = 1,
            ["ArcaneSpellDamage"] = 0.7,
            ["Mana"] = 0.06666666666666667,
            ["ResilienceRating"] = 1,
            ["Agility"] = 1,
            ["ExpertiseRating"] = 1,
            ["YellowSocket"] = 16,
            ["Spirit"] = 1,
            ["ArmorPenetration"] = 0.1428571428571429,
            ["FireSpellDamage"] = 0.7,
            ["Dps"] = 3.4,
            ["Strength"] = 1,
            ["ParryRating"] = 1,
            ["Health"] = 0.06666666666666667,
            ["Hp5"] = 2.5,
            ["SpellPower"] = 0.8571428571428571,
            ["Mp5"] = 2.5,
            ["Ap"] = 0.5,
            ["CritRating"] = 1,
            ["SpellPenetration"] = 0.8,
            ["NatureResist"] = 1,
            ["HasteRating"] = 1,
            ["ShadowSpellDamage"] = 0.7,
            ["DefenseRating"] = 1,
            ["FrostResist"] = 1,
            ["FrostSpellDamage"] = 0.7,
            ["BlockValue"] = 0.65,
            ["BlockRating"] = 1,
            ["RedSocket"] = 16,
            ["Stamina"] = 0.6666666666666666,
            ["Armor"] = 0.1,
            ["DodgeRating"] = 1,
            ["NatureSpellDamage"] = 0.7,
            ["HolySpellDamage"] = 0.7,
            ["AllResist"] = 2.5,
            ["ShadowResist"] = 1,
            ["HitRating"] = 1,
            ["BlueSocket"] = 16,
            ["FireResist"] = 1,
            ["Rap"] = 0.4,
            ["MetaSocket"] = 16,
            ["ColorlessSocket"] = 16,
         },
         ["SmartGemSocketing"] = true,
      },
   },
   ["LastKeybindingsSet"] = 1,
}


4. Repeat for any other characters you wish to utilise Pawn on.
5. Load WoW with no crashes. :)
Back to top
View user's profileSend private message
Display posts from previous:   
Post new topic   Reply to topic    Official Pawn forums Forum Index -> Bug Reports All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum